use strict;
my $str = '١|٢|٣٣٣٣٣|٤٥٥٥|٥|٦|٧|٨|٩';
my $regex = qr/[١٢٣٤٥٦٧٨٩]{4,}/p;
my $subst = '';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";