// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"[١٢٣٤٥٦٧٨٩]{4,}").unwrap();
let string = "١|٢|٣٣٣٣٣|٤٥٥٥|٥|٦|٧|٨|٩";
let substitution = "";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}