const regex = /[١٢٣٤٥٦٧٨٩]{4,}/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('[١٢٣٤٥٦٧٨٩]{4,}', 'g')
const str = `١|٢|٣٣٣٣٣|٤٥٥٥|٥|٦|٧|٨|٩`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);