package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`[١٢٣٤٥٦٧٨٩]{4,}`)
var str = `١|٢|٣٣٣٣٣|٤٥٥٥|٥|٦|٧|٨|٩`
var substitution = ""
fmt.Println(re.ReplaceAllString(str, substitution))
}