import Foundation
let pattern = #"[١٢٣٤٥٦٧٨٩]{4,}"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"١|٢|٣٣٣٣٣|٤٥٥٥|٥|٦|٧|٨|٩"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #""#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)