using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"[١٢٣٤٥٦٧٨٩]{4,}";
string substitution = @"";
string input = @"١|٢|٣٣٣٣٣|٤٥٥٥|٥|٦|٧|٨|٩";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}