# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(?<=Discount\s)\d+(\.\d+)?/$1/g;t' <<< "Discount 7.5%
Discount 15%
Discount 10%
Discount 5.433%
fee 11%"