use strict;
my $str = 'Discount 7.5%
Discount 15%
Discount 10%
Discount 5.433%
fee 11%';
my $regex = qr/(?<=Discount\s)\d+(\.\d+)?/p;
my $subst = '$1';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";