import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?<=Discount\\s)\\d+(\\.\\d+)?";
final String string = "Discount 7.5%\n"
+ "Discount 15%\n"
+ "Discount 10%\n"
+ "Discount 5.433%\n"
+ "fee 11%";
final String subst = "$1";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}