import Foundation
let pattern = #"(?<=Discount\s)\d+(\.\d+)?"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
Discount 7.5%
Discount 15%
Discount 10%
Discount 5.433%
fee 11%
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"$1"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)