using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<=Discount\s)\d+(\.\d+)?";
string substitution = @"$1";
string input = @"Discount 7.5%
Discount 15%
Discount 10%
Discount 5.433%
fee 11%";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}