const regex = /(?<=Discount\s)\d+(\.\d+)?/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?<=Discount\\s)\\d+(\\.\\d+)?', 'g')
const str = `Discount 7.5%
Discount 15%
Discount 10%
Discount 5.433%
fee 11%`;
const subst = `$1`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);