import re
regex = re.compile(r"(?<=Discount\s)\d+(\.\d+)?")
test_str = ("Discount 7.5%\n"
"Discount 15%\n"
"Discount 10%\n"
"Discount 5.433%\n"
"fee 11%")
subst = "$1"
result = regex.sub(subst, test_str)
if result:
print(result)