using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?:greasyfork|sleazyfork).org\/.*";
string substitution = @"";
string input = @"https://greasyfork.org/scripts/404275/code
// @include /(?:greasyfork|sleazyfork).org/.*/
// @include /.*greasyfork.org.*/
// @include /greasyfork.org/
// @include /^https://(?:greasyfork|sleazyfork).org/.*/
";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution, 1);
}
}