import re
regex = re.compile(r"(?:greasyfork|sleazyfork).org\/.*")
test_str = ("https://greasyfork.org/scripts/404275/code\n\n"
"// @include /(?:greasyfork|sleazyfork).org/.*/\n"
"// @include /.*greasyfork.org.*/\n"
"// @include /greasyfork.org/\n"
"// @include /^https://(?:greasyfork|sleazyfork).org/.*/\n\n")
subst = ""
result = regex.sub(subst, test_str, count=1)
if result:
print(result)