package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?:greasyfork|sleazyfork).org\/.*`)
var str = []byte(`https://greasyfork.org/scripts/404275/code
// @include /(?:greasyfork|sleazyfork).org/.*/
// @include /.*greasyfork.org.*/
// @include /greasyfork.org/
// @include /^https://(?:greasyfork|sleazyfork).org/.*/
`)
var substitution = []byte("")
var count = 1 // negative counter is equivalent to global case (replace all)
str = re.ReplaceAllStringFunc(str, func(s string) string {
if count == 0 {
return s
}
count -= 1
return re.ReplaceAllString(s, substitution)
})
fmt.Println(string(str))
}