import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?:greasyfork|sleazyfork).org\\/.*";
final String string = "https://greasyfork.org/scripts/404275/code\n\n"
+ "// @include /(?:greasyfork|sleazyfork).org/.*/\n"
+ "// @include /.*greasyfork.org.*/\n"
+ "// @include /greasyfork.org/\n"
+ "// @include /^https://(?:greasyfork|sleazyfork).org/.*/\n\n";
final String subst = "";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceFirst(subst);
System.out.println("Substitution result: " + result);
}
}