const regex = /(?:greasyfork|sleazyfork).org\/.*/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?:greasyfork|sleazyfork).org\\\/.*', '')
const str = `https://greasyfork.org/scripts/404275/code
// @include /(?:greasyfork|sleazyfork).org/.*/
// @include /.*greasyfork.org.*/
// @include /greasyfork.org/
// @include /^https://(?:greasyfork|sleazyfork).org/.*/
`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);