# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/^(?=.)((?:-(?>(?=0)|\d*)|\d*))(.*)$/$1/gm;t' <<< "-
-1
-10
-0
--
-01
0122
122
"