use strict;
my $str = '-
-1
-10
-0
--
-01
0122
122
';
my $regex = qr/^(?=.)((?:-(?>(?=0)|\d*)|\d*))(.*)$/mp;
my $subst = '$1';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";