#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)^(?=.)((?:-(?>(?=0)|\d*)|\d*))(.*)$"
Local $sString = "-" & @CRLF & _
"-1" & @CRLF & _
"-10" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"-0" & @CRLF & _
"--" & @CRLF & _
"" & @CRLF & _
"-01" & @CRLF & _
"0122" & @CRLF & _
"122" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
""
Local $sSubst = "$1"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)