# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"^(?=.)((?:-(?>(?=0)|\d*)|\d*))(.*)$"
test_str = ("-\n"
"-1\n"
"-10\n\n\n"
"-0\n"
"--\n\n"
"-01\n"
"0122\n"
"122\n\n\n")
subst = "$1"
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0, re.MULTILINE)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.