re = /^(?=.)((?:-(?>(?=0)|\d*)|\d*))(.*)$/m
str = '-
-1
-10
-0
--
-01
0122
122
'
subst = '$1'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result