$re = '/^(?=.)((?:-(?>(?=0)|\d*)|\d*))(.*)$/m';
$str = '-
-1
-10
-0
--
-01
0122
122
';
$subst = "$1";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;