import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?=.)((?:-(?>(?=0)|\\d*)|\\d*))(.*)$";
final String string = "-\n"
+ "-1\n"
+ "-10\n\n\n"
+ "-0\n"
+ "--\n\n"
+ "-01\n"
+ "0122\n"
+ "122\n\n\n";
final String subst = "$1";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}