using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(?=.)((?:-(?>(?=0)|\d*)|\d*))(.*)$";
string substitution = @"$1";
string input = @"-
-1
-10
-0
--
-01
0122
122
";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}