const regex = /^(?=.)((?:-(?>(?=0)|\d*)|\d*))(.*)$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(?=.)((?:-(?>(?=0)|\\d*)|\\d*))(.*)$', 'gm')
const str = `-
-1
-10
-0
--
-01
0122
122
`;
const subst = `$1`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);