#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?:<a.*?>\s*[<img src="]*)(.+?)(?="?>?\s*(?:<\/a>|$))"
Local $sString = "<tr>" & @CRLF & _
" <td class=""> <a href="#">Processo 1</a> </td>" & @CRLF & _
" <td> <a> <img src="LINK DA IMAGEM"> </a> </td>" & @CRLF & _
" <td> <a> <img src="LINK DA IMAGEM"> " & @CRLF & _
"</a> " & @CRLF & _
"</td>" & @CRLF & _
" <td> <a> <img src="LINK DA IMAGEM"> </a> </td>" & @CRLF & _
"</tr>" & @CRLF & _
"<tr>" & @CRLF & _
" <td class=""> <a href="#">Processo 2</a> </td>" & @CRLF & _
" <td>" & @CRLF & _
" <a>" & @CRLF & _
" <img src="LINK DA IMAGEM"> </a> </td>" & @CRLF & _
" <td> <a> <img src="LINK DA IMAGEM"> </a> </td>" & @CRLF & _
" <td> <a> <img src="LINK DA IMAGEM"> </a> </td>" & @CRLF & _
"</tr>" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")