re = /(?:<a.*?>\s*[<img src="]*)(.+?)(?="?>?\s*(?:<\/a>|$))/
str = '<tr>
<td class=""> <a href="#">Processo 1</a> </td>
<td> <a> <img src="LINK DA IMAGEM"> </a> </td>
<td> <a> <img src="LINK DA IMAGEM">
</a>
</td>
<td> <a> <img src="LINK DA IMAGEM"> </a> </td>
</tr>
<tr>
<td class=""> <a href="#">Processo 2</a> </td>
<td>
<a>
<img src="LINK DA IMAGEM"> </a> </td>
<td> <a> <img src="LINK DA IMAGEM"> </a> </td>
<td> <a> <img src="LINK DA IMAGEM"> </a> </td>
</tr>
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end