import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?:<a.*?>\\s*[<img src=\"]*)(.+?)(?=\"?>?\\s*(?:<\\/a>|$))";
final String string = "<tr>\n"
+ " <td class=\"\"> <a href=\"#\">Processo 1</a> </td>\n"
+ " <td> <a> <img src=\"LINK DA IMAGEM\"> </a> </td>\n"
+ " <td> <a> <img src=\"LINK DA IMAGEM\"> \n"
+ "</a> \n"
+ "</td>\n"
+ " <td> <a> <img src=\"LINK DA IMAGEM\"> </a> </td>\n"
+ "</tr>\n"
+ "<tr>\n"
+ " <td class=\"\"> <a href=\"#\">Processo 2</a> </td>\n"
+ " <td>\n"
+ " <a>\n"
+ " <img src=\"LINK DA IMAGEM\"> </a> </td>\n"
+ " <td> <a> <img src=\"LINK DA IMAGEM\"> </a> </td>\n"
+ " <td> <a> <img src=\"LINK DA IMAGEM\"> </a> </td>\n"
+ "</tr>\n";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}