import Foundation
let pattern = #"(?:<a.*?>\s*[<img src="]*)(.+?)(?="?>?\s*(?:<\/a>|$))"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = ##"""
<tr>
<td class=""> <a href="#">Processo 1</a> </td>
<td> <a> <img src="LINK DA IMAGEM"> </a> </td>
<td> <a> <img src="LINK DA IMAGEM">
</a>
</td>
<td> <a> <img src="LINK DA IMAGEM"> </a> </td>
</tr>
<tr>
<td class=""> <a href="#">Processo 2</a> </td>
<td>
<a>
<img src="LINK DA IMAGEM"> </a> </td>
<td> <a> <img src="LINK DA IMAGEM"> </a> </td>
<td> <a> <img src="LINK DA IMAGEM"> </a> </td>
</tr>
"""##
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)