$re = '/(?:<a.*?>\s*[<img src="]*)(.+?)(?="?>?\s*(?:<\/a>|$))/';
$str = '<tr>
<td class=""> <a href="#">Processo 1</a> </td>
<td> <a> <img src="LINK DA IMAGEM"> </a> </td>
<td> <a> <img src="LINK DA IMAGEM">
</a>
</td>
<td> <a> <img src="LINK DA IMAGEM"> </a> </td>
</tr>
<tr>
<td class=""> <a href="#">Processo 2</a> </td>
<td>
<a>
<img src="LINK DA IMAGEM"> </a> </td>
<td> <a> <img src="LINK DA IMAGEM"> </a> </td>
<td> <a> <img src="LINK DA IMAGEM"> </a> </td>
</tr>
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);