use strict;
my $str = '<tr>
<td class=""> <a href="#">Processo 1</a> </td>
<td> <a> <img src="LINK DA IMAGEM"> </a> </td>
<td> <a> <img src="LINK DA IMAGEM">
</a>
</td>
<td> <a> <img src="LINK DA IMAGEM"> </a> </td>
</tr>
<tr>
<td class=""> <a href="#">Processo 2</a> </td>
<td>
<a>
<img src="LINK DA IMAGEM"> </a> </td>
<td> <a> <img src="LINK DA IMAGEM"> </a> </td>
<td> <a> <img src="LINK DA IMAGEM"> </a> </td>
</tr>
';
my $regex = qr/(?:<a.*?>\s*[<img src="]*)(.+?)(?="?>?\s*(?:<\/a>|$))/p;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}