# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(?:<a.*?>\s*[<img src=\"]*)(.+?)(?=\"?>?\s*(?:<\/a>|$))"
test_str = ("<tr>\n"
" <td class=\"\"> <a href=\"#\">Processo 1</a> </td>\n"
" <td> <a> <img src=\"LINK DA IMAGEM\"> </a> </td>\n"
" <td> <a> <img src=\"LINK DA IMAGEM\"> \n"
"</a> \n"
"</td>\n"
" <td> <a> <img src=\"LINK DA IMAGEM\"> </a> </td>\n"
"</tr>\n"
"<tr>\n"
" <td class=\"\"> <a href=\"#\">Processo 2</a> </td>\n"
" <td>\n"
" <a>\n"
" <img src=\"LINK DA IMAGEM\"> </a> </td>\n"
" <td> <a> <img src=\"LINK DA IMAGEM\"> </a> </td>\n"
" <td> <a> <img src=\"LINK DA IMAGEM\"> </a> </td>\n"
"</tr>\n")
matches = re.finditer(regex, test_str)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.