using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?:<a.*?>\s*[<img src=""]*)(.+?)(?=""?>?\s*(?:<\/a>|$))";
string input = @"<tr>
<td class=""> <a href=""#"">Processo 1</a> </td>
<td> <a> <img src=""LINK DA IMAGEM""> </a> </td>
<td> <a> <img src=""LINK DA IMAGEM"">
</a>
</td>
<td> <a> <img src=""LINK DA IMAGEM""> </a> </td>
</tr>
<tr>
<td class=""> <a href=""#"">Processo 2</a> </td>
<td>
<a>
<img src=""LINK DA IMAGEM""> </a> </td>
<td> <a> <img src=""LINK DA IMAGEM""> </a> </td>
<td> <a> <img src=""LINK DA IMAGEM""> </a> </td>
</tr>
";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}