# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/\b(?i:lag|max|pctrange)\b(*SKIP)(*F)|a/_/g;t' <<< "lag(a,1) + 252*a + max(3a*2) / 5*pctrange(a,10)"