const regex = /\b(?i:lag|max|pctrange)\b(*SKIP)(*F)|a/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\b(?i:lag|max|pctrange)\\b(*SKIP)(*F)|a', 'g')
const str = `lag(a,1) + 252*a + max(3a*2) / 5*pctrange(a,10)`;
const subst = `_`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);