package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`\b(?i:lag|max|pctrange)\b(*SKIP)(*F)|a`)
var str = `lag(a,1) + 252*a + max(3a*2) / 5*pctrange(a,10)`
var substitution = "_"
fmt.Println(re.ReplaceAllString(str, substitution))
}