$re = '/\b(?i:lag|max|pctrange)\b(*SKIP)(*F)|a/';
$str = 'lag(a,1) + 252*a + max(3a*2) / 5*pctrange(a,10)';
$subst = "_";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;