import Foundation
let pattern = #"\b(?i:lag|max|pctrange)\b(*SKIP)(*F)|a"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"lag(a,1) + 252*a + max(3a*2) / 5*pctrange(a,10)"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"_"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)