re = /\b(?i:lag|max|pctrange)\b(*SKIP)(*F)|a/
str = 'lag(a,1) + 252*a + max(3a*2) / 5*pctrange(a,10)'
subst = '_'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result