use strict;
my $str = 'lag(a,1) + 252*a + max(3a*2) / 5*pctrange(a,10)';
my $regex = qr/\b(?i:lag|max|pctrange)\b(*SKIP)(*F)|a/p;
my $subst = '_';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";