using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\b(?i:lag|max|pctrange)\b(*SKIP)(*F)|a";
string substitution = @"_";
string input = @"lag(a,1) + 252*a + max(3a*2) / 5*pctrange(a,10)";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}