# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(^\d{9}$)/0\1/gm;t' <<< "123456789
123456789
123456789
123456789
0123456789
0123456789
0123456789
0123456789"