using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(^\d{9}$)";
string substitution = @"0\1";
string input = @"123456789
123456789
123456789
123456789
0123456789
0123456789
0123456789
0123456789";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}