use strict;
my $str = '123456789
123456789
123456789
123456789
0123456789
0123456789
0123456789
0123456789';
my $regex = qr/(^\d{9}$)/mp;
my $subst = '0\\1';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";