import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(^\\d{9}$)";
final String string = "123456789\n"
+ "123456789\n"
+ "123456789\n"
+ "123456789\n"
+ "0123456789\n"
+ "0123456789\n"
+ "0123456789\n"
+ "0123456789";
final String subst = "0\\1";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}