const regex = /(^\d{9}$)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(^\\d{9}$)', 'gm')
const str = `123456789
123456789
123456789
123456789
0123456789
0123456789
0123456789
0123456789`;
const subst = `0\1`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);