$re = '/(^\d{9}$)/m';
$str = '123456789
123456789
123456789
123456789
0123456789
0123456789
0123456789
0123456789';
$subst = "0\1";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;