#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)(^\d{9}$)"
Local $sString = "123456789" & @CRLF & _
"123456789" & @CRLF & _
"123456789" & @CRLF & _
"123456789" & @CRLF & _
"0123456789" & @CRLF & _
"0123456789" & @CRLF & _
"0123456789" & @CRLF & _
"0123456789"
Local $sSubst = "0\1"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)